Android 14 будет блокировать устаревшие приложения

Android 14 будет блокировать устаревшие приложения

Чтобы уменьшить вероятность вредоносных программ, Android 14 начнет полностью блокировать установку приложений, предназначенных для устаревших версий Android.

9to5Google сообщает: уже много лет рекомендации для Google Play Store гарантировали, что разработчики Android постоянно обновляют свои приложения, чтобы использовать новейшие функции и меры безопасности платформы Android.

Буквально в этом месяце правила были обновлены, требуя, чтобы недавно добавленные в Play Store приложения были ориентированы как минимум на Android 12.

До этого момента эти минимальные требования к уровню API применялись только к приложениям, предназначенным для магазина Google Play.

Если разработчик хочет создать приложение для более старой версии, он может сделать это, просто попросив своих пользователей загрузить APK-файл вручную.

Точно так же, если приложение для Android не обновлялось с момента изменения правил, Play Store продолжит предоставлять приложение тем, кто уже установил его ранее.

Согласно недавно опубликованному изменению кода, Android 14 ужесточает требования к API, полностью блокируя установку устаревших приложений.

Это изменение заблокирует загрузку определенных APK-файлов пользователями, а также запретит магазинам приложений устанавливать те же самые приложения.

Первоначально устройства Android 14 будут блокировать только приложения, предназначенные для особенно старых версий Android.

Однако со временем планируется повысить порог до Android 6.0 (Marshmallow), при этом у Google есть механизм для «постепенного наращивания [его]».

Тем не менее, скорее всего, каждый производитель устройств будет решать, какой порог для устаревших приложений должен быть включен или вообще включен.

В отчете отмечается, что по-прежнему можно будет установить устаревшую версию приложения «через командную оболочку, используя новый флаг».